Unable to see/find UI library from Manage Packages

Hello everyone


  1. extracted a UI descriptor as a UI library from Object Repository,
  2. published it to a local folder (nupkg), and
  3. added the local folder in Manage Packages in Settings (with Custom UI name) in a new blank project (Modern design experience).

But I’m unable to see it in the Manage Packages → Custom UI feed

Am I missing something w.r.t. UI libraries?





Apologies, the forum doesn’t let me post more than one media in a post since I’ve just joined.


Hello @abhinav !
Thanks for your question. Hmmm, it seems really odd.
Firstly make sure you are indeed publishing a library (and not a process by accident). The publish window should have this title:

I tried it at my side and it works okay. I don’t see anything suspicious at your screenshots. This also looks good but you can check that the options “filtering” by the funnel icons are not narrowing down the results so it is not visible.

To narrow down that this is not error related to your package, try to download and put in same folder this one: (rename extension to .nupkg)
Calculator.Descriptors.1.0.3.zip (245.2 KB)
Some more ideas:

  • Double check the path. Try some basic path such as C:\Packages.
  • Try to restart Studio

Let me know if any of this helped :wink:

1 Like

Thanks @roman.hruska
The problem was it was a prerelease nupkg so including it from the filter helped. Thanks! :slight_smile:

1 Like